summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorvlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2010-08-17 12:45:22 +0000
committervlefevre <vlefevre@280ebfd0-de03-0410-8827-d642c229c3f4>2010-08-17 12:45:22 +0000
commit06499bb95c98e277cf06990c39a9d8cd230a0771 (patch)
tree8718f17c1763599ccbcac81a50834bff160ab40c /Makefile.am
parent43d8270c29cbdb7c1decfc6b37914a3455041fa9 (diff)
downloadmpfr-06499bb95c98e277cf06990c39a9d8cd230a0771.tar.gz
Added tools/ck-version-info Perl script with the same license as
Makefile.am, to check consistency concerning -version-info and that the -version-info value is up-to-date. Updated Makefile.am: * In dist-hook, replaced complex sh code by a call to ck-version-info. * Distribute ck-version-info (EXTRA_DIST). git-svn-id: svn://scm.gforge.inria.fr/svn/mpfr/trunk@7091 280ebfd0-de03-0410-8827-d642c229c3f4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 5 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index c417565d2..caa0e99f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,19 +18,14 @@ nobase_dist_doc_DATA = AUTHORS BUGS COPYING COPYING.LESSER NEWS TODO \
examples/ReadMe examples/divworst.c examples/rndo-add.c examples/sample.c \
examples/version.c
-EXTRA_DIST = PATCHES VERSION tools/get_patches.sh
+EXTRA_DIST = PATCHES VERSION tools/ck-version-info tools/get_patches.sh
-# In a "make dist", check that libtool -version-info value is up-to-date.
-# But if the VERSION file contains "-dev", this is not checked.
+# In a "make dist", check consistency concerning -version-info
+# and if the VERSION file doesn't end with "-dev", check that
+# the -version-info value is up-to-date.
# Note: this is a heuristic, to detect some mistakes.
dist-hook:
- grep -q -e -dev $(srcdir)/VERSION || { \
- mv=`sed -n "s/^\([0-9][0-9]*\)\.\([0-9][0-9]*\)\..*/\1\\\\\\.\2/p" $(srcdir)/VERSION` && \
- pl=`sed -n "s/^$$mv\.\([0-9][0-9]*\).*/\1/p" $(srcdir)/VERSION` && \
- printf "mv=%s / pl=%s\n" "$$mv" "$$pl" && \
- vinfo=`sed -n "s/^# *$$mv\.x *\([0-9][0-9]*\):x:\([0-9][0-9]*\)/\1:$$pl:\2/p" $(srcdir)/src/Makefile.am` && \
- printf "vinfo=%s\n" "$$vinfo" && \
- grep -q -e "-version-info $$vinfo$$" $(srcdir)/src/Makefile.am; }
+ cd $(srcdir) && tools/ck-version-info
# The following needs to be removed once GNU Automake 1.11 support is added.
DIST_ARCHIVES = $(distdir).tar.gz $(distdir).tar.bz2 $(distdir).tar.xz \