summaryrefslogtreecommitdiff
path: root/tools/mpcheck/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/mpcheck/Makefile.am')
-rw-r--r--tools/mpcheck/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/tools/mpcheck/Makefile.am b/tools/mpcheck/Makefile.am
new file mode 100644
index 0000000..77ed6b0
--- /dev/null
+++ b/tools/mpcheck/Makefile.am
@@ -0,0 +1,31 @@
+## tools/mpcheck/Makefile.am -- Process this file with automake to produce Makefile.in
+##
+## Copyright (C) 2014 CNRS
+## Copyright (C) 2020 INRIA
+##
+## This file is part of GNU MPC.
+##
+## GNU MPC is free software; you can redistribute it and/or modify it under
+## the terms of the GNU Lesser General Public License as published by the
+## Free Software Foundation; either version 3 of the License, or (at your
+## option) any later version.
+##
+## GNU MPC is distributed in the hope that it will be useful, but WITHOUT ANY
+## WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS
+## FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
+## more details.
+##
+## You should have received a copy of the GNU Lesser General Public License
+## along with this program. If not, see http://www.gnu.org/licenses/ .
+
+AM_CPPFLAGS = -I$(top_srcdir)/src
+AM_DEFAULT_SOURCE_EXT = .c
+
+LDADD = $(top_builddir)/src/libmpc.la -lm
+
+BINARIES = mpcheck-float mpcheck-double mpcheck-longdouble mpcheck-float128
+EXTRA_PROGRAMS = $(BINARIES)
+CLEANFILES = $(BINARIES)
+
+mpcheck : $(BINARIES)
+