summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2019-05-29 09:28:05 +0200
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2019-05-29 09:28:05 +0200
commit84a35aa0caddf31849bf70d1d561d33eed4b81ea (patch)
tree65b584669b44271ca35e8b84014a9db5a57cfa5b /Makefile.am
parent52ff4f42c52166dafa7e619f95f458c9e3873165 (diff)
downloadmm-common-84a35aa0caddf31849bf70d1d561d33eed4b81ea.tar.gz
Add support for building mm-common with meson
mm-common can be built with either autotools or meson, but the files it installs and copies to other modules are only useful for modules that use autotools.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 49858c9..4f7ad94 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -124,6 +124,15 @@ dist_noinst_SCRIPTS = autogen.sh $(skeletonmm_script_files)
CLEANFILES = $(man1_MANS) $(doc_DATA)
MAINTAINERCLEANFILES = $(dist_doctags_DATA)
+# Distribute files needed when building mm-common with meson.
+EXTRA_DIST = \
+ meson.build \
+ meson_options.txt \
+ util/meson_aux/extra-dist-cmd.sh \
+ util/meson_aux/extra-install-cmd.sh \
+ util/meson_aux/libstdcxx-tag.sh \
+ util/meson_aux/skeletonmm-tarball.sh
+
# Remote location of the GNU libstdc++ Doxygen tag file.
libstdcxx_tag_url = http://gcc.gnu.org/onlinedocs/libstdc++/latest-doxygen/libstdc++.tag