summaryrefslogtreecommitdiff
path: root/test cases/unit/39 python extmodule/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test cases/unit/39 python extmodule/meson.build')
-rw-r--r--test cases/unit/39 python extmodule/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/test cases/unit/39 python extmodule/meson.build b/test cases/unit/39 python extmodule/meson.build
new file mode 100644
index 000000000..479865482
--- /dev/null
+++ b/test cases/unit/39 python extmodule/meson.build
@@ -0,0 +1,23 @@
+project('Python extension module', 'c',
+ default_options : ['buildtype=release'])
+
+py_mod = import('python')
+
+py = py_mod.find_installation(get_option('python'), required : false)
+
+if py.found()
+ py_dep = py.dependency()
+
+ if py_dep.found()
+ subdir('ext')
+
+ test('extmod',
+ py,
+ args : files('blaster.py'),
+ env : ['PYTHONPATH=' + pypathdir])
+ else
+ error('MESON_SKIP_TEST: Python libraries not found, skipping test.')
+ endif
+else
+ error('MESON_SKIP_TEST: Python not found, skipping test.')
+endif