summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bca6b1f5c41..961ca8ecc6b 100644
--- a/meson.build
+++ b/meson.build
@@ -2167,10 +2167,16 @@ endif
# as GCC LTO drops them. See: https://bugs.freedesktop.org/show_bug.cgi?id=109391
gcc_lto_quirk = (cc.get_id() == 'gcc') ? ['-fno-lto'] : []
+devenv = environment()
+
subdir('include')
subdir('bin')
subdir('src')
+if meson.version().version_compare('>= 0.58')
+ meson.add_devenv(devenv)
+endif
+
lines = ['',
'prefix: ' + get_option('prefix'),
'libdir: ' + get_option('libdir'),