summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2018-10-11 16:00:04 +0100
committerEric Engestrom <eric.engestrom@intel.com>2018-11-13 17:25:02 +0000
commit4fa2fb35245448f8b5d81fb5b37afec4f343f18a (patch)
tree8c2c00cfda195026e777789e91b6f9dba185e3e9 /src/meson.build
parent7df80de6e645ba8c20d97f5f2b1f6c12aa962e29 (diff)
downloadmesa-4fa2fb35245448f8b5d81fb5b37afec4f343f18a.tar.gz
meson: fix wayland-less builds
Those empty variables in the !wayland case are useless and running that meson.build with them breaks the build: [287/850] Generating wayland-drm-client-protocol.h with a custom command. FAILED: src/egl/wayland/wayland-drm/wayland-drm-client-protocol.h client-header ../src/egl/wayland/wayland-drm/wayland-drm.xml src/egl/wayland/wayland-drm/wayland-drm-client-protocol.h /bin/sh: client-header: command not found ninja: build stopped: subcommand failed. Fixes: d1992255bb29054fa5176 "meson: Add build Intel "anv" vulkan driver" Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/meson.build b/src/meson.build
index 2c0bff73432..0d0ecf2c530 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -51,7 +51,9 @@ subdir('util')
subdir('mapi')
# TODO: opengl
subdir('compiler')
-subdir('egl/wayland/wayland-drm')
+if with_platform_wayland
+ subdir('egl/wayland/wayland-drm')
+endif
if with_any_vk
subdir('vulkan')
endif