summaryrefslogtreecommitdiff
path: root/src/gbm/Makefile.am
diff options
context:
space:
mode:
authorRob Herring <robh@kernel.org>2016-05-03 21:02:47 -0500
committerEmil Velikov <emil.l.velikov@gmail.com>2016-05-23 12:07:46 +0100
commit8aeb6d768b4285f600d09f38d0b406adf46c251d (patch)
treec4ad438adb7e6862da2b8dbc77a3963a9188f073 /src/gbm/Makefile.am
parent1f4869a2089c6172feff382e177d74ac68c241a7 (diff)
downloadmesa-8aeb6d768b4285f600d09f38d0b406adf46c251d.tar.gz
gbm: Add map/unmap functions
This adds map and unmap functions to GBM utilizing the DRIimage extension mapImage/unmapImage functions or existing internal mapping for dumb buffers. Unlike prior attempts, this version provides a region to map and usage flags for the mapping. The operation follows the same semantics as the gallium transfer_map() function. This was tested with GBM based gralloc on Android. Signed-off-by: Rob Herring <robh@kernel.org> [Emil Velikov: drop no longer relevant hunk from commit message.] Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'src/gbm/Makefile.am')
-rw-r--r--src/gbm/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/gbm/Makefile.am b/src/gbm/Makefile.am
index 45fb762620a..aba8d1ec351 100644
--- a/src/gbm/Makefile.am
+++ b/src/gbm/Makefile.am
@@ -41,10 +41,12 @@ libgbm_la_SOURCES += \
AM_CFLAGS += \
-DDEFAULT_DRIVER_DIR='"$(DRI_DRIVER_SEARCH_DIR)"' \
- $(LIBDRM_CFLAGS)
+ $(LIBDRM_CFLAGS) \
+ $(PTHREADSTUBS_CFLAGS)
libgbm_la_LIBADD += \
- $(LIBDRM_LIBS)
+ $(LIBDRM_LIBS) \
+ $(PTHREADSTUBS_LIBS)
endif
TESTS = gbm-symbols-check