summaryrefslogtreecommitdiff
path: root/src/gbm/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2017-09-01 17:39:36 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2017-09-19 19:02:34 +0100
commit2785090a2ae9d959ce87e40629281a8079fd2f49 (patch)
treea336febaff46fb82542c30d03224485ad649bcea /src/gbm/Makefile.am
parent1d0be5b3fe548ee33d4520092f583c76d42510a6 (diff)
downloadmesa-2785090a2ae9d959ce87e40629281a8079fd2f49.tar.gz
configure.ac: split the wayland client/server confusion
At the moment wayland-clients, such as the Vulkan drivers were over-linking against libwayland-server.so. That went unnoticed, since both client and server code uses the wl*interface symbols, which are present in both libwayland-client.so and libwayland-server.so. I've looked at correcting that, although that's orthogonal to this fix. Note: wayland-egl does _not_ depend on wayland-client, although it does need wayland-egl.h. There's no distinct package that provides it (I have a WIP on the topic) so current solution will do for now. v2: Rebase with the "...inline wayland_drm_buffer_get" patch removed. Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'src/gbm/Makefile.am')
-rw-r--r--src/gbm/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/gbm/Makefile.am b/src/gbm/Makefile.am
index f5fa81c7c96..805208a3ca9 100644
--- a/src/gbm/Makefile.am
+++ b/src/gbm/Makefile.am
@@ -31,8 +31,8 @@ libgbm_la_LIBADD = \
$(DLOPEN_LIBS)
if HAVE_PLATFORM_WAYLAND
-AM_CFLAGS += $(WAYLAND_CFLAGS)
-libgbm_la_LIBADD += $(top_builddir)/src/egl/wayland/wayland-drm/libwayland-drm.la $(WAYLAND_LIBS)
+AM_CFLAGS += $(WAYLAND_SERVER_CFLAGS)
+libgbm_la_LIBADD += $(top_builddir)/src/egl/wayland/wayland-drm/libwayland-drm.la $(WAYLAND_SERVER_LIBS)
endif
if HAVE_DRI2