summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-09-19 14:18:55 +0100
committerEric Engestrom <eric.engestrom@intel.com>2019-09-25 17:27:54 +0100
commit93df862b6affb6b8507e40601212a58012bfa873 (patch)
tree1c789af81c81d79f155067f25611664990f46a14 /meson.build
parentdb2ca45102753f9af62d4fe339599a357239b781 (diff)
downloadmesa-93df862b6affb6b8507e40601212a58012bfa873.tar.gz
meson: re-add incorrect pkg-config files with GLVND for backward compatibility
This is a bit counter-intuitive, but the issue is that GLVND is broken in versions <= 1.1.1, so we need to keep wrongly providing these files to cover up their mistake, otherwise the rest of the world ends up broken. Suggested-by: Dylan Baker <dylan@pnwbakers.com> Cc: mesa-stable@lists.freedesktop.org Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 4a80d6a55ad..0e46fde5edc 100644
--- a/meson.build
+++ b/meson.build
@@ -1328,6 +1328,10 @@ endif
dep_glvnd = null_dep
if with_glvnd
dep_glvnd = dependency('libglvnd', version : '>= 0.2.0')
+ # GLVND until commit 0dfaea2bcb7cdcc785f9 ("Add pkg-config files for EGL, GL,
+ # GLES, and GLX.") was missing its pkg-config files, forcing every vendor to
+ # provide them and the distro maintainers to resolve the conflict.
+ glvnd_missing_pc_files = dep_glvnd.version().version_compare('< 1.2.0')
pre_args += '-DUSE_LIBGLVND=1'
endif