summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2019-05-31 16:16:22 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-09-10 20:36:47 +0000
commit8424209a421274552d7eed42154750df40a3f87a (patch)
treef8e396ec5831c24be6a3059933b5094930ca7dfe /meson.build
parenta1a870319951f49c4169040e5efb3d550c6882f0 (diff)
downloadmesa-8424209a421274552d7eed42154750df40a3f87a.tar.gz
meson: Make shared-glapi a combo
So it can auto off for windows, but on elsewhere. Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 9 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index db21d4dbce4..2d6ac036475 100644
--- a/meson.build
+++ b/meson.build
@@ -89,7 +89,14 @@ if host_machine.system() == 'windows'
endif
endif
with_opengl = get_option('opengl')
-with_shared_glapi = get_option('shared-glapi')
+
+# Default shared glapi off for windows, on elsewhere.
+_sg = get_option('shared-glapi')
+if _sg == 'auto'
+ with_shared_glapi = host_machine.system() != 'windows'
+else
+ with_shared_glapi = _sg == 'true'
+endif
# shared-glapi is required if at least two OpenGL APIs are being built
if not with_shared_glapi
@@ -115,7 +122,7 @@ with_gles1 = with_gles1 != 'false'
with_gles2 = with_gles2 != 'false'
with_any_opengl = with_opengl or with_gles1 or with_gles2
# Only build shared_glapi if at least one OpenGL API is enabled
-with_shared_glapi = get_option('shared-glapi') and with_any_opengl
+with_shared_glapi = with_shared_glapi and with_any_opengl
system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux'].contains(host_machine.system())