summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-04-18 13:29:26 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-10-10 16:33:04 -0700
commit597a063551fa413c611f5499a78ce59700fc0461 (patch)
treedb87728d6ddfa853009bbd29e938d56684bcfd9e /meson.build
parentb97a34101789e6b653043c75fd7358847b22bc5b (diff)
downloadmesa-597a063551fa413c611f5499a78ce59700fc0461.tar.gz
meson: fix gallium-osmesa to build for windows
v2: - set so_version to '' (only affects windows) - always set lib prefix to 'lib', even on msvc v5: - key NO_EXPORTS on shared glapi instead of gles. Acked-by: Kristian H. Kristensen <hoegsberg@google.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6657de4de62..8c5ae52ba37 100644
--- a/meson.build
+++ b/meson.build
@@ -1450,7 +1450,11 @@ if with_osmesa != 'none'
if with_osmesa == 'gallium' and not with_gallium_softpipe
error('OSMesa gallium requires gallium softpipe or llvmpipe.')
endif
- osmesa_lib_name = 'OSMesa'
+ if host_machine.system() == 'windows'
+ osmesa_lib_name = 'osmesa'
+ else
+ osmesa_lib_name = 'OSMesa'
+ endif
osmesa_bits = get_option('osmesa-bits')
if osmesa_bits != '8'
if with_dri or with_glx != 'disabled'