summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-09-23 18:37:01 +0100
committerEric Engestrom <eric.engestrom@intel.com>2019-09-24 19:39:24 +0100
commit3fd0afd5e3f7d2c5b8b5bfb77a111decfb193240 (patch)
tree664a070ad7788f40b746cbfe043e8c8a66853dbf /meson.build
parent30f639c181ce46c8761389946589616eb06a977b (diff)
downloadmesa-3fd0afd5e3f7d2c5b8b5bfb77a111decfb193240.tar.gz
meson: drop -Wno-foo bug workaround for Meson < 0.46
This was a workaround for a bug in Meson that was fixed in 0.46 [1]. [1] https://github.com/mesonbuild/meson/pull/2284 Fixes: f7b6a8d12fdc446e3251 ("meson: bump required version to 0.46") Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build27
1 files changed, 9 insertions, 18 deletions
diff --git a/meson.build b/meson.build
index e1a1bb819fa..ce0eb154edc 100644
--- a/meson.build
+++ b/meson.build
@@ -893,6 +893,8 @@ foreach a : ['-Werror=implicit-function-declaration',
'-Werror=incompatible-pointer-types',
'-Werror=format',
'-Wformat-security',
+ '-Wno-missing-field-initializers',
+ '-Wno-format-truncation',
'-fno-math-errno',
'-fno-trapping-math', '-Qunused-arguments']
if cc.has_argument(a)
@@ -900,12 +902,6 @@ foreach a : ['-Werror=implicit-function-declaration',
endif
endforeach
-foreach a : ['missing-field-initializers', 'format-truncation']
- if cc.has_argument('-W' + a)
- c_args += '-Wno-' + a
- endif
-endforeach
-
c_vis_args = []
if cc.has_argument('-fvisibility=hidden')
c_vis_args += '-fvisibility=hidden'
@@ -916,6 +912,9 @@ cpp_args = []
foreach a : ['-Werror=return-type',
'-Werror=format',
'-Wformat-security',
+ '-Wno-non-virtual-dtor',
+ '-Wno-missing-field-initializers',
+ '-Wno-format-truncation',
'-fno-math-errno', '-fno-trapping-math',
'-Qunused-arguments']
if cpp.has_argument(a)
@@ -923,19 +922,11 @@ foreach a : ['-Werror=return-type',
endif
endforeach
-# For some reason, the test for -Wno-foo always succeeds with gcc, even if the
-# option is not supported. Hence, check for -Wfoo instead.
-
-foreach a : ['non-virtual-dtor', 'missing-field-initializers', 'format-truncation']
- if cpp.has_argument('-W' + a)
- cpp_args += '-Wno-' + a
- endif
-endforeach
-
no_override_init_args = []
-foreach a : ['override-init', 'initializer-overrides']
- if cc.has_argument('-W' + a)
- no_override_init_args += '-Wno-' + a
+foreach a : ['-Wno-override-init',
+ '-Wno-initializer-overrides']
+ if cc.has_argument(a)
+ no_override_init_args += a
endif
endforeach