summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-08-28 00:58:18 +0100
committerEric Engestrom <eric.engestrom@intel.com>2019-09-06 22:26:29 +0100
commit1b8764638a1a589612df7b1f34bcc04cb7d3d053 (patch)
tree3e3b9db92684a6db989770cb4869be6449675d9f /meson.build
parent2406b35151c253fc5fb89ddc07dece9fdaa88ca5 (diff)
downloadmesa-1b8764638a1a589612df7b1f34bcc04cb7d3d053.tar.gz
meson/scons/android: drop now-unused HAVE_LLVM
Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Acked-by: Michel Dänzer <mdaenzer@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index e3c96039afb..db21d4dbce4 100644
--- a/meson.build
+++ b/meson.build
@@ -1273,12 +1273,8 @@ if _llvm != 'false'
with_llvm = dep_llvm.found()
endif
if with_llvm
- _llvm_version = dep_llvm.version().split('.')
- pre_args += [
- '-DLLVM_AVAILABLE',
- '-DHAVE_LLVM=0x0@0@0@1@'.format(_llvm_version[0], _llvm_version[1]),
- '-DMESA_LLVM_VERSION_STRING="@0@"'.format(dep_llvm.version()),
- ]
+ pre_args += '-DLLVM_AVAILABLE'
+ pre_args += '-DMESA_LLVM_VERSION_STRING="@0@"'.format(dep_llvm.version())
# LLVM can be built without rtti, turning off rtti changes the ABI of C++
# programs, so we need to build all C++ code in mesa without rtti as well to