summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-04-05 16:12:51 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-09-10 20:36:47 +0000
commit0caa229dcb52d0da14bb45b29781fb781e723d68 (patch)
treefd01935898370b1ef11ec9e9390fd5fd81c97b0e /meson.build
parent2595b7c997a6f77ea94c708165bc5f7448936b0f (diff)
downloadmesa-0caa229dcb52d0da14bb45b29781fb781e723d68.tar.gz
meson: fix dl detection on non cygwin windows
v4: - Don't run checks on Windows that will always fail Reviewed-by: Eric Anholt <eric@anholt.net> (v3) Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 9 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 65afcb4ec60..c700d64eb97 100644
--- a/meson.build
+++ b/meson.build
@@ -1113,14 +1113,15 @@ if build_machine.system() != 'darwin'
endif
# check for dl support
-if cc.has_function('dlopen')
- dep_dl = null_dep
-else
- dep_dl = cc.find_library('dl')
-endif
-if cc.has_function('dladdr', dependencies : dep_dl)
- # This is really only required for megadrivers
- pre_args += '-DHAVE_DLADDR'
+dep_dl = null_dep
+if host_machine.system() != 'windows'
+ if not cc.has_function('dlopen')
+ dep_dl = cc.find_library('dl')
+ endif
+ if cc.has_function('dladdr', dependencies : dep_dl)
+ # This is really only required for megadrivers
+ pre_args += '-DHAVE_DLADDR'
+ endif
endif
if cc.has_function('dl_iterate_phdr')