summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLuis Felipe Strano Moraes <luis.strano@intel.com>2021-05-12 16:12:36 -0700
committerMarge Bot <eric+marge@anholt.net>2021-07-01 16:42:07 +0000
commit7f8652d72d8171eda78a26523aca42f26a8b16b2 (patch)
tree0418872ef72e68fa789f053f2a22bbd808d25416 /meson.build
parent669b6889e4b0ed4e3ca597dee8a1ab6834bac560 (diff)
downloadmesa-7f8652d72d8171eda78a26523aca42f26a8b16b2.tar.gz
meson: print information about layers being built as part of summary
reviewed-by: Dylan Baker <dylan@pnwbakers.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/11673>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 74dc4ad0743..c515f7fcacf 100644
--- a/meson.build
+++ b/meson.build
@@ -79,6 +79,7 @@ if with_tools.contains('all')
endif
with_clc = false
+with_any_vulkan_layers = get_option('vulkan-layers').length() != 0
with_intel_tools = with_tools.contains('intel') or with_tools.contains('intel-ui')
with_imgui = with_intel_tools or with_vulkan_overlay_layer
@@ -2174,6 +2175,9 @@ lines += ''
if with_any_vk
lines += 'Vulkan drivers: ' + ' '.join(_vulkan_drivers)
lines += 'Vulkan ICD dir: ' + with_vulkan_icd_dir
+ if with_any_vulkan_layers
+ lines += 'Vulkan layers: ' + ' '.join(get_option('vulkan-layers'))
+ endif
else
lines += 'Vulkan drivers: no'
endif