summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-05-17 13:44:30 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-05-03 10:58:05 -0700
commitff9bf223c24143260a975f45963eb90f40565c57 (patch)
treec8ec393ae985491da3d8812b36a8be586dbfaaad /meson.build
parentf5eafc2dc6a68c9c2c2660dff528de1ecdedf4dc (diff)
downloadmesa-ff9bf223c24143260a975f45963eb90f40565c57.tar.gz
meson: make nm binary optional
This makes nm not required, but used if found. In general I imagine that this means that on windows nm wont be found, and on other platforms it will. v2: - fix gbm and egl symbols check tests to only be run if nm is found - reword commit message to reflect the code change Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 87ce5f7872e..f72bdc946bf 100644
--- a/meson.build
+++ b/meson.build
@@ -1502,8 +1502,11 @@ endif
pkg = import('pkgconfig')
+prog_nm = find_program('nm', required : false)
env_test = environment()
-env_test.set('NM', find_program('nm').path())
+if prog_nm.found()
+ env_test.set('NM', prog_nm.path())
+endif
# This quirk needs to be applied to sources with functions defined in assembly
# as GCC LTO drops them. See: https://bugs.freedesktop.org/show_bug.cgi?id=109391