summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorBas Nieuwenhuizen <bas@basnieuwenhuizen.nl>2019-08-03 18:44:44 +0200
committerBas Nieuwenhuizen <bas@basnieuwenhuizen.nl>2019-08-03 20:18:17 +0200
commit9f37c9903b87f86a533bfaffa72f0ecb285b02b2 (patch)
tree94192c3b35f90699cf748ad66d0f3b444b286e6c /meson.build
parentd7ca1efc6c814947af5b0a0c75b40673b61c31c4 (diff)
downloadmesa-9f37c9903b87f86a533bfaffa72f0ecb285b02b2.tar.gz
mesa: Rename GLX_USE_TLS to USE_ELF_TLS.
These days it is not GLX only and it does not work with all TLS implementations. Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 2ca672e492f..61fc8649d55 100644
--- a/meson.build
+++ b/meson.build
@@ -375,9 +375,9 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
endif
endif
-# Android uses emutls for versions <= P/28. For GLX_USE_TLS we need ELF TLS.
+# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
if not with_platform_android or get_option('platform-sdk-version') >= 29
- pre_args += '-DGLX_USE_TLS'
+ pre_args += '-DUSE_ELF_TLS'
endif
if with_glx != 'disabled'