summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2019-04-03 15:40:22 -0700
committerEric Anholt <eric@anholt.net>2019-04-26 14:59:32 -0700
commit7e069832a05ebd5948d3ef95d3b5028156c829b3 (patch)
tree97a5313b588e12bec4af70f07757594780a8c1ff /meson.build
parenta8a0e5c03cab8dc0e73d761fdf44874f7f45be55 (diff)
downloadmesa-7e069832a05ebd5948d3ef95d3b5028156c829b3.tar.gz
kmsro: Add support for V3D.
Like vc4, we expect to have SOCs with various displays that have a single V3D instance for rendering. v2: Add v3d to the list of drivers that make enabling kmsro valid. Acked-by: Rob Clark <robdclark@chromium.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0e8aa25d336..58d383749d3 100644
--- a/meson.build
+++ b/meson.build
@@ -217,7 +217,7 @@ endif
if with_dri_i915 and with_gallium_i915
error('Only one i915 provider can be built')
endif
-if with_gallium_kmsro and not (with_gallium_vc4 or with_gallium_etnaviv or with_gallium_freedreno or with_gallium_panfrost or with_gallium_lima)
+if with_gallium_kmsro and not (with_gallium_v3d or with_gallium_vc4 or with_gallium_etnaviv or with_gallium_freedreno or with_gallium_panfrost or with_gallium_lima)
error('kmsro driver requires one or more renderonly drivers (vc4, etnaviv, freedreno, panfrost, lima)')
endif
if with_gallium_tegra and not with_gallium_nouveau