summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMarc Dietrich <marvin24@gmx.de>2018-01-23 15:49:43 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2018-01-26 19:53:00 +0000
commit4d0b43117de8a02bb3dd19810227b8c415155f67 (patch)
tree1bd680b09f825f7e66194ed8de424127046f8a57 /meson.build
parent99a48002a288691d6b2f531c31073ae2d4965c3b (diff)
downloadmesa-4d0b43117de8a02bb3dd19810227b8c415155f67.tar.gz
meson: fix some defines misspelled errors in meson.build
Defines - HAVE_FUNC_ATTRIBUTE_RETURNS_NONNULL - HAVE_FUNC_ATTRIBUTE_VISIBILITY were misspelled. Signed-off-by: Marc Dietrich <marvin24@gmx.de> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com> (cherry picked from commit 911ca587f8785a90702f88d3c9044b7149e6d2b3)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index f3179c38062..97619f786bb 100644
--- a/meson.build
+++ b/meson.build
@@ -692,14 +692,14 @@ if cc.compiles('struct __attribute__((packed)) foo { int bar; };',
endif
if cc.compiles('int *foo(void) __attribute__((returns_nonnull));',
name : '__attribute__((returns_nonnull))')
- pre_args += '-DHAVE_FUNC_ATTRIBUTE_NONNULL'
+ pre_args += '-DHAVE_FUNC_ATTRIBUTE_RETURNS_NONNULL'
endif
if cc.compiles('''int foo_def(void) __attribute__((visibility("default")));
int foo_hid(void) __attribute__((visibility("hidden")));
int foo_int(void) __attribute__((visibility("internal")));
int foo_pro(void) __attribute__((visibility("protected")));''',
name : '__attribute__((visibility(...)))')
- pre_args += '-DHAVE_FUNC_ATTRIBUTE_VISBILITY'
+ pre_args += '-DHAVE_FUNC_ATTRIBUTE_VISIBILITY'
endif
if cc.compiles('int foo(void) { return 0; } int bar(void) __attribute__((alias("foo")));',
name : '__attribute__((alias(...)))')