summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMike Blumenkrantz <michael.blumenkrantz@gmail.com>2021-09-20 14:59:38 -0400
committerMarge Bot <eric+marge@anholt.net>2021-09-20 22:47:38 +0000
commitb61e9345c11f87d7839a2a62bfd89071d097b6d6 (patch)
treeec19c5ab5094090284264898b7c8b7930f3c08d4 /meson.build
parentaff177a0adb60e499468faedc5e0bf0306854514 (diff)
downloadmesa-b61e9345c11f87d7839a2a62bfd89071d097b6d6.tar.gz
build: fix nine compilation with only zink enabled as a gallium driver
fixes #5360 Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/12943>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c2a8dc30576..56c19bc881a 100644
--- a/meson.build
+++ b/meson.build
@@ -819,7 +819,7 @@ if with_gallium_st_nine
error('The nine state tracker requires gallium softpipe/llvmpipe.')
elif not (with_gallium_radeonsi or with_gallium_nouveau or with_gallium_r600
or with_gallium_r300 or with_gallium_svga or with_gallium_i915
- or with_gallium_iris or with_gallium_crocus)
+ or with_gallium_iris or with_gallium_crocus or with_gallium_zink)
error('The nine state tracker requires at least one non-swrast gallium driver.')
endif
if not with_dri3