summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Vesely <jan.vesely@rutgers.edu>2014-10-23 17:17:07 -0400
committerEmil Velikov <emil.l.velikov@gmail.com>2014-10-29 18:52:46 +0000
commitaf9551e68c8c964a3a80d74b6ed543b800318b33 (patch)
treee640fc3c7d3c09764dad64109ec9758d254e3905 /configure.ac
parent402ab50bedf9fba7654e63a6f2e808714714284d (diff)
downloadmesa-af9551e68c8c964a3a80d74b6ed543b800318b33.tar.gz
configure: include llvm systemlibs when using static llvm
v2: drop -WL,--exclude-libs, it's not necessary fix tabs/spaces Cc: mesa-stable@lists.freedesktop.org Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=70410 Tested-by: Kai Wasserbäch <kai@dev.carbon-project.org> Signed-off-by: Jan Vesely <jan.vesely@rutgers.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 03f1bca8692..765a3a173d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2007,7 +2007,12 @@ if test "x$MESA_LLVM" != x0; then
dnl already added all of these objects to LLVM_LIBS.
fi
else
- AC_MSG_WARN([Building mesa with staticly linked LLVM may cause compilation issues])
+ AC_MSG_WARN([Building mesa with statically linked LLVM may cause compilation issues])
+ dnl We need to link to llvm system libs when using static libs
+ dnl However, only llvm 3.5+ provides --system-libs
+ if test $LLVM_VERSION_MAJOR -eq 3 -a $LLVM_VERSION_MINOR -ge 5; then
+ LLVM_LIBS="$LLVM_LIBS `$LLVM_CONFIG --system-libs`"
+ fi
fi
fi