summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2016-12-07 14:38:10 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2017-05-19 19:46:54 +0100
commit1914c814a6c4aaaf03c26f6c20a9871ebc98895f (patch)
tree87d7bb56f2f9f3796b8347958c01b3d79b7c8ad1 /configure.ac
parent63e11ac2b5c99fa351be5f61a035f72384609a1c (diff)
downloadmesa-1914c814a6c4aaaf03c26f6c20a9871ebc98895f.tar.gz
configure: error out if building OMX w/o supported platform
Cc: <mesa-stable@lists.freedesktop.org> Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 90b70a62a92..e713a96ea00 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2062,6 +2062,12 @@ if test "x$enable_xa" = xyes; then
fi
AM_CONDITIONAL(HAVE_ST_XA, test "x$enable_xa" = xyes)
+if echo $platforms | grep -q "x11\|drm"; then
+ have_omx_platform=yes
+else
+ have_omx_platform=no
+fi
+
if echo $platforms | grep -q "x11\|drm\|wayland"; then
have_va_platform=yes
else
@@ -2080,7 +2086,7 @@ if test -n "$with_gallium_drivers" -a "x$with_gallium_drivers" != xswrast; then
PKG_CHECK_EXISTS([vdpau >= $VDPAU_REQUIRED], [enable_vdpau=yes], [enable_vdpau=no])
fi
- if test "x$enable_omx" = xauto; then
+ if test "x$enable_omx" = xauto -a "x$have_omx_platform" = xyes; then
PKG_CHECK_EXISTS([libomxil-bellagio >= $LIBOMXIL_BELLAGIO_REQUIRED], [enable_omx=yes], [enable_omx=no])
fi
@@ -2121,6 +2127,9 @@ fi
AM_CONDITIONAL(HAVE_ST_VDPAU, test "x$enable_vdpau" = xyes)
if test "x$enable_omx" = xyes; then
+ if test "x$have_omx_platform" != xyes; then
+ AC_MSG_ERROR([OMX requires at least one of the x11 or drm platforms])
+ fi
PKG_CHECK_MODULES([OMX], [libomxil-bellagio >= $LIBOMXIL_BELLAGIO_REQUIRED])
gallium_st="$gallium_st omx"
fi