summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Ekstrand <jason.ekstrand@intel.com>2018-09-13 09:56:20 -0500
committerJason Ekstrand <jason.ekstrand@intel.com>2018-10-10 13:13:12 -0500
commit328d4d080bce128ff422fbfbd7271ef4ede38320 (patch)
tree6e557472267ec1a2cfa0b69122c76b9a7c5931cc /configure.ac
parenta9be8dddfedb1d19e43b900bdfd33731d3c390c4 (diff)
downloadmesa-328d4d080bce128ff422fbfbd7271ef4ede38320.tar.gz
util: Add tests for fast integer division by constants
While I generally trust rediculousfish to have done his homework, we've made some adjustments to suit the needs of mesa and it'd be good to test those. Also, there's no better place than unit tests to clearly document the different edge cases of the different methods. Reviewed-by: Marek Olšák <marek.olsak@amd.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 34689826c98..520948b0518 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3195,6 +3195,7 @@ AC_CONFIG_FILES([Makefile
src/mesa/main/tests/Makefile
src/mesa/state_tracker/tests/Makefile
src/util/Makefile
+ src/util/tests/fast_idiv_by_const/Makefile
src/util/tests/hash_table/Makefile
src/util/tests/set/Makefile
src/util/tests/string_buffer/Makefile