summaryrefslogtreecommitdiff
path: root/plugin/auth_pipe/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugin/auth_pipe/CMakeLists.txt')
-rw-r--r--plugin/auth_pipe/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/plugin/auth_pipe/CMakeLists.txt b/plugin/auth_pipe/CMakeLists.txt
new file mode 100644
index 00000000000..0a2eacad264
--- /dev/null
+++ b/plugin/auth_pipe/CMakeLists.txt
@@ -0,0 +1,19 @@
+# Copyright (c) 2010, Oracle and/or its affiliates. All rights reserved.
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License as
+# published by the Free Software Foundation; version 2 of the
+# License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+IF(WIN32)
+ MYSQL_ADD_PLUGIN(auth_pipe auth_pipe.c MODULE_ONLY)
+ENDIF()