summaryrefslogtreecommitdiff
path: root/packaging/rpm-oel/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/rpm-oel/CMakeLists.txt')
-rw-r--r--packaging/rpm-oel/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/packaging/rpm-oel/CMakeLists.txt b/packaging/rpm-oel/CMakeLists.txt
new file mode 100644
index 00000000000..fb1a1c1600c
--- /dev/null
+++ b/packaging/rpm-oel/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Copyright (c) 2012, 2013, Oracle and/or its affiliates. All rights reserved.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+
+IF(UNIX)
+ SET(prefix ${CMAKE_INSTALL_PREFIX})
+
+ SET(SPECFILENAME "mysql.spec")
+ IF("${VERSION}" MATCHES "-ndb-")
+ STRING(REGEX REPLACE "^.*-ndb-" "" NDBVERSION "${VERSION}")
+ SET(SPECFILENAME "mysql-cluster-${NDBVERSION}.spec")
+ ENDIF()
+
+ # Left in current directory, to be taken during build
+ CONFIGURE_FILE(mysql.spec.in ${CMAKE_CURRENT_BINARY_DIR}/${SPECFILENAME} @ONLY)
+
+ FOREACH(fedfile my.cnf my_config.h mysql_config.sh
+ mysqld.service mysql-systemd-start mysql.conf
+ filter-requires.sh filter-provides.sh
+ mysql-embedded-check.c mysql.init)
+ CONFIGURE_FILE(${fedfile} ${CMAKE_CURRENT_BINARY_DIR}/${fedfile} COPYONLY)
+ ENDFOREACH()
+ENDIF()
+