summaryrefslogtreecommitdiff
path: root/ndb/src/common/transporter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ndb/src/common/transporter/Makefile.am')
-rw-r--r--ndb/src/common/transporter/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/ndb/src/common/transporter/Makefile.am b/ndb/src/common/transporter/Makefile.am
new file mode 100644
index 00000000000..8c46cc29051
--- /dev/null
+++ b/ndb/src/common/transporter/Makefile.am
@@ -0,0 +1,17 @@
+
+noinst_LTLIBRARIES = libtransporter.la
+
+libtransporter_la_SOURCES = \
+ Transporter.cpp \
+ SendBuffer.cpp \
+ TCP_Transporter.cpp \
+ TransporterRegistry.cpp \
+ Packer.cpp \
+ SHM_Transporter.cpp
+
+include $(top_srcdir)/ndb/config/common.mk.am
+include $(top_srcdir)/ndb/config/type_util.mk.am
+INCLUDES += -I$(top_srcdir)/ndb/include/kernel -I$(top_srcdir)/ndb/include/transporter
+
+# Don't update the files from bitkeeper
+%::SCCS/s.%