summaryrefslogtreecommitdiff
path: root/libmysqld/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libmysqld/CMakeLists.txt')
-rw-r--r--libmysqld/CMakeLists.txt69
1 files changed, 6 insertions, 63 deletions
diff --git a/libmysqld/CMakeLists.txt b/libmysqld/CMakeLists.txt
index 7f311844c6a..0d61460ad58 100644
--- a/libmysqld/CMakeLists.txt
+++ b/libmysqld/CMakeLists.txt
@@ -87,70 +87,13 @@ FOREACH(rpath ${VIO_SOURCES})
SET(LIB_SOURCES ${LIB_SOURCES} ../vio/${rpath})
ENDFOREACH(rpath)
-# Engines
-INCLUDE(${CMAKE_SOURCE_DIR}/storage/heap/CMakeLists.txt)
-FOREACH(rpath ${HEAP_SOURCES})
- SET(LIB_SOURCES ${LIB_SOURCES} ../storage/heap/${rpath})
-ENDFOREACH(rpath)
-
-INCLUDE(${CMAKE_SOURCE_DIR}/storage/myisam/CMakeLists.txt)
-FOREACH(rpath ${MYISAM_SOURCES})
- SET(LIB_SOURCES ${LIB_SOURCES} ../storage/myisam/${rpath})
-ENDFOREACH(rpath)
-
-INCLUDE(${CMAKE_SOURCE_DIR}/storage/myisammrg/CMakeLists.txt)
-FOREACH(rpath ${MYISAMMRG_SOURCES})
- SET(LIB_SOURCES ${LIB_SOURCES} ../storage/myisammrg/${rpath})
-ENDFOREACH(rpath)
-
-IF(WITH_ARCHIVE_STORAGE_ENGINE)
- INCLUDE(${CMAKE_SOURCE_DIR}/storage/archive/CMakeLists.txt)
- FOREACH(rpath ${ARCHIVE_SOURCES})
- SET(LIB_SOURCES ${LIB_SOURCES} ../storage/archive/${rpath})
- ENDFOREACH(rpath)
-ENDIF(WITH_ARCHIVE_STORAGE_ENGINE)
-
-IF(WITH_BLACKHOLE_STORAGE_ENGINE)
- INCLUDE(${CMAKE_SOURCE_DIR}/storage/blackhole/CMakeLists.txt)
- FOREACH(rpath ${BLACKHOLE_SOURCES})
- SET(LIB_SOURCES ${LIB_SOURCES} ../storage/blackhole/${rpath})
- ENDFOREACH(rpath)
-ENDIF(WITH_BLACKHOLE_STORAGE_ENGINE)
-
-IF(WITH_EXAMPLE_STORAGE_ENGINE)
- INCLUDE(${CMAKE_SOURCE_DIR}/storage/example/CMakeLists.txt)
- FOREACH(rpath ${EXAMPLE_SOURCES})
- SET(LIB_SOURCES ${LIB_SOURCES} ../storage/example/${rpath})
- ENDFOREACH(rpath)
-ENDIF(WITH_EXAMPLE_STORAGE_ENGINE)
-
-IF(WITH_FEDERATED_STORAGE_ENGINE)
- INCLUDE(${CMAKE_SOURCE_DIR}/storage/federated/CMakeLists.txt)
- FOREACH(rpath ${FEDERATED_SOURCES})
- SET(LIB_SOURCES ${LIB_SOURCES} ../storage/federated/${rpath})
- ENDFOREACH(rpath)
-ENDIF(WITH_FEDERATED_STORAGE_ENGINE)
-
-IF(WITH_INNOBASE_STORAGE_ENGINE)
- INCLUDE(${CMAKE_SOURCE_DIR}/storage/xtradb/CMakeLists.txt)
- FOREACH(rpath ${INNOBASE_SOURCES})
- SET(LIB_SOURCES ${LIB_SOURCES} ../storage/xtradb/${rpath})
- ENDFOREACH(rpath)
-ENDIF(WITH_INNOBASE_STORAGE_ENGINE)
-
-IF(WITH_CSV_STORAGE_ENGINE)
- INCLUDE(${CMAKE_SOURCE_DIR}/storage/csv/CMakeLists.txt)
- FOREACH(rpath ${CSV_SOURCES})
- SET(LIB_SOURCES ${LIB_SOURCES} ../storage/csv/${rpath})
- ENDFOREACH(rpath)
-ENDIF(WITH_CSV_STORAGE_ENGINE)
-
-IF(WITH_MARIA_STORAGE_ENGINE)
- INCLUDE(${CMAKE_SOURCE_DIR}/storage/maria/CMakeLists.txt)
- FOREACH(rpath ${MARIA_SOURCES})
- SET(LIB_SOURCES ${LIB_SOURCES} ../storage/maria/${rpath})
+FOREACH (ENGINE_LIB ${MYSQLD_STATIC_ENGINE_LIBS})
+ INCLUDE(${CMAKE_SOURCE_DIR}/storage/${ENGINE_LIB}/CMakeLists.txt)
+ STRING(TOUPPER ${ENGINE_LIB} ENGINE_LIB_UPPER)
+ FOREACH(rpath ${${ENGINE_LIB_UPPER}_SOURCES})
+ SET(LIB_SOURCES ${LIB_SOURCES} ${CMAKE_SOURCE_DIR}/storage/${ENGINE_LIB}/${rpath})
ENDFOREACH(rpath)
-ENDIF(WITH_MARIA_STORAGE_ENGINE)
+ENDFOREACH(ENGINE_LIB)
SET(SOURCE_SUBLIBS FALSE)