summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2009-09-30 15:35:01 +0200
committerVladislav Vaintroub <vvaintroub@mysql.com>2009-09-30 15:35:01 +0200
commiteaba74fee5611369c02e50eb6da707f8f29cf302 (patch)
tree7f9c3b3991fa7d5f18931f146c63848ea7405fd6 /tests/CMakeLists.txt
parentb73763e0f913a1b3e841cbe91f9d11802cbf054c (diff)
downloadmariadb-git-eaba74fee5611369c02e50eb6da707f8f29cf302.tar.gz
Backport http://lists.mysql.com/commits/57778
2677 Vladislav Vaintroub 2008-11-04 CMakeLists.txt files cleanup - remove SAFEMALLOC and SAFE_MUTEX definitions that were present in *each* CMakeLists.txt. Instead, put them into top level CMakeLists.txt, but disable on Windows, because a) SAFEMALLOC does not add any functionality that is not already present in Debug C runtime ( and 2 safe malloc one on top of the other only unnecessarily slows down the server) b)SAFE_MUTEX does not work on Windows and have been explicitely disabled on Windows with #undef previously. Fortunately, ntdll does pretty good job identifying l problems with CRITICAL_SECTIONs. DebugBreak()s on using uninited critical section, unlocking unowned critical section) -Also, remove occationally used -D_DEBUG (added by compiler anyway) sql/udf_example.c: use unixish end of line
Diffstat (limited to 'tests/CMakeLists.txt')
-rwxr-xr-xtests/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 270aaf53c20..0ee8769cd23 100755
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -13,8 +13,6 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-
-SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
ADD_DEFINITIONS("-DMYSQL_CLIENT")
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)