summaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@montyprogram.com>2011-05-15 13:38:18 +0200
committerVladislav Vaintroub <wlad@montyprogram.com>2011-05-15 13:38:18 +0200
commit19f0d6b2d9930f83688943b8f98a8b7397584df9 (patch)
tree08c9b040b07dfcf337c7a94244b0dd5ff5ccb7ff /tests/CMakeLists.txt
parent2982738e48cf47162251d318c44b13801ea4804f (diff)
downloadmariadb-git-19f0d6b2d9930f83688943b8f98a8b7397584df9.tar.gz
Small CMake fixes :
- add version info for the client library, dynamic plugins and some utilities - do not recompile client library sources 3 times (for mysqlclient , mysqlclient_notls and libmysql) One time is sufficient, so get rid of mysqlclient_notls, and link static client library to the shared. - remove incremental linking flag
Diffstat (limited to 'tests/CMakeLists.txt')
-rwxr-xr-xtests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 4095f2ec342..967ebae2e22 100755
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -20,9 +20,9 @@ ADD_DEFINITIONS("-DMYSQL_CLIENT")
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
ADD_EXECUTABLE(mysql_client_test mysql_client_test.c ../mysys/my_memmem.c)
-TARGET_LINK_LIBRARIES(mysql_client_test mysqlclient_notls wsock32)
+TARGET_LINK_LIBRARIES(mysql_client_test mysqlclient wsock32)
ADD_EXECUTABLE(bug25714 bug25714.c)
-TARGET_LINK_LIBRARIES(bug25714 mysqlclient_notls wsock32)
+TARGET_LINK_LIBRARIES(bug25714 mysqlclient wsock32)
INSTALL(TARGETS mysql_client_test DESTINATION bin COMPONENT Test)