summaryrefslogtreecommitdiff
path: root/storage/xtradb/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Black <daniel.black@au.ibm.com>2016-11-01 11:01:48 +1100
committerDaniel Black <daniel.black@au.ibm.com>2016-11-01 11:09:47 +1100
commitab0e5031e41d0aa72dd77a6dced9eacc8be5c548 (patch)
treefc6339f99f70c3229e6df42a9f2152524af87fc6 /storage/xtradb/CMakeLists.txt
parent71e11bce34339a69576321d6c40838fa65208dc7 (diff)
downloadmariadb-git-ab0e5031e41d0aa72dd77a6dced9eacc8be5c548.tar.gz
MDEV-11195: Correct enablement of NUMA in innodb/xtradb
No -DHAVE_LIBNUMA=1 was passed to the source compile (and the global include/my_config.h wasn't used). This also is Linux only so corrected the cmake macro. Fixed indenting in cmake macro. Removed NUMA defination from include/my_config.h as its only in the storage engine. Thanks Elena Stepanova and Vladislav Vaintroub for the detailed list of bugs/questions. Signed-off-by: Daniel Black <daniel.black@au.ibm.com>
Diffstat (limited to 'storage/xtradb/CMakeLists.txt')
-rw-r--r--storage/xtradb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/storage/xtradb/CMakeLists.txt b/storage/xtradb/CMakeLists.txt
index 7e0bb9103d2..6512f247e52 100644
--- a/storage/xtradb/CMakeLists.txt
+++ b/storage/xtradb/CMakeLists.txt
@@ -23,6 +23,7 @@ INCLUDE(lzo)
INCLUDE(lzma)
INCLUDE(bzip2)
INCLUDE(snappy)
+INCLUDE(numa)
MYSQL_CHECK_LZ4()
MYSQL_CHECK_LZO()