summaryrefslogtreecommitdiff
path: root/storage/xtradb/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Lindström <jan.lindstrom@mariadb.com>2015-05-07 13:04:03 +0300
committerJan Lindström <jan.lindstrom@mariadb.com>2015-05-07 13:04:03 +0300
commit8350ea05141c55c17807e9654c61cad481542480 (patch)
tree91c794e94a9989e87bf732bbcc20d165d66a7da5 /storage/xtradb/CMakeLists.txt
parentf704b3335f3155f38f951d706c0fe2060acb06c3 (diff)
downloadmariadb-git-8350ea05141c55c17807e9654c61cad481542480.tar.gz
Fix compiler error if compiler does not support c99 style
initializers.
Diffstat (limited to 'storage/xtradb/CMakeLists.txt')
-rw-r--r--storage/xtradb/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/storage/xtradb/CMakeLists.txt b/storage/xtradb/CMakeLists.txt
index 1c3bf769ef4..2f8e42427d0 100644
--- a/storage/xtradb/CMakeLists.txt
+++ b/storage/xtradb/CMakeLists.txt
@@ -180,6 +180,8 @@ IF(HAVE_IB_ATOMIC_PTHREAD_T_GCC)
ADD_DEFINITIONS(-DHAVE_IB_ATOMIC_PTHREAD_T_GCC=1)
ENDIF()
+CHECK_C_SOURCE_COMPILES("struct t1{ int a; char *b; }; struct t1 c= { .a=1, .b=0 }; main() { }" HAVE_C99_INITIALIZERS)
+
ENDIF(NOT MSVC)
# Solaris atomics