summaryrefslogtreecommitdiff
path: root/storage/xtradb/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Lindström <jplindst@mariadb.org>2013-11-14 12:57:28 +0200
committerJan Lindström <jplindst@mariadb.org>2013-11-14 12:57:28 +0200
commit5d1ec1b95147ead6e1f8a6690b7deee690257abf (patch)
tree34acfec3218f20f7f4906ad80f5b0df7071c1fea /storage/xtradb/CMakeLists.txt
parent4f0dabcfba1c1c539c836266cd7a19f32eee0ad0 (diff)
downloadmariadb-git-5d1ec1b95147ead6e1f8a6690b7deee690257abf.tar.gz
MDEV-5247: DB locked up at btr0cur.c line 568. There is inconsistent and non logical usage of have_LRU_mutex and incorrect value on ha_innodb.cc when buf_LRU_free_block is called. Additionally, for future long semaphore wait cases added a new configuration variable innodb_use_stacktrace. If this variable is true a signal handler for SIGUSR2 is installed when InnoDB server starts and when a long semaphore wait is detected at sync/sync0array.c we send SIGUSR2 signal to waiting thread and thread that has acuired RW-latch. For both threads a full stacktrace is produced as well as its is possible.
Diffstat (limited to 'storage/xtradb/CMakeLists.txt')
-rw-r--r--storage/xtradb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/storage/xtradb/CMakeLists.txt b/storage/xtradb/CMakeLists.txt
index 4c098049fd4..f128833f1e7 100644
--- a/storage/xtradb/CMakeLists.txt
+++ b/storage/xtradb/CMakeLists.txt
@@ -274,6 +274,7 @@ SET(INNOBASE_SOURCES btr/btr0btr.c btr/btr0cur.c btr/btr0pcur.c btr/btr0sea.c
mem/mem0mem.c mem/mem0pool.c
mtr/mtr0log.c mtr/mtr0mtr.c
os/os0file.c os/os0proc.c os/os0sync.c os/os0thread.c
+ os/os0stacktrace.c
page/page0cur.c page/page0page.c page/page0zip.c
que/que0que.c
handler/ha_innodb.cc handler/handler0alter.cc handler/i_s.cc