summaryrefslogtreecommitdiff
path: root/storage/xtradb/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2017-08-15 09:50:31 +0200
committerSergei Golubchik <serg@mariadb.org>2017-08-15 09:50:31 +0200
commit48fe832650ae2dc0c2eaa957abfa959b0a2670aa (patch)
tree8d21953ea13d4fe8eecefae81979a72423ec71f5 /storage/xtradb/CMakeLists.txt
parent3e20a42bfbf6b4b887c2822c46923ad6167be962 (diff)
parent7581fb23e2d8126378296e987d84641d7bbd8914 (diff)
downloadmariadb-git-48fe832650ae2dc0c2eaa957abfa959b0a2670aa.tar.gz
Merge branch '10.0' into 10.1
Diffstat (limited to 'storage/xtradb/CMakeLists.txt')
-rw-r--r--storage/xtradb/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/storage/xtradb/CMakeLists.txt b/storage/xtradb/CMakeLists.txt
index 77d8ca7fdbc..f66a142ecd8 100644
--- a/storage/xtradb/CMakeLists.txt
+++ b/storage/xtradb/CMakeLists.txt
@@ -94,9 +94,9 @@ CHECK_FUNCTION_EXISTS(sched_getcpu HAVE_SCHED_GETCPU)
IF(NOT MSVC)
# either define HAVE_IB_GCC_ATOMIC_BUILTINS or not
- # workaround for gcc 4.1.2 RHEL5/x86, gcc atomic ops only work under -march=i686
+ # workaround for old gcc on x86, gcc atomic ops only work under -march=i686
IF(CMAKE_SYSTEM_PROCESSOR STREQUAL "i686" AND CMAKE_COMPILER_IS_GNUCC AND
- CMAKE_C_COMPILER_VERSION VERSION_LESS "4.1.3")
+ CMAKE_C_COMPILER_VERSION VERSION_LESS "4.4.0")
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -march=i686")
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=i686")
ENDIF()