summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorunknown <joerg@mysql.com>2006-06-22 14:28:05 +0200
committerunknown <joerg@mysql.com>2006-06-22 14:28:05 +0200
commit62683b70fb3a6c386449480dd5f55da690676086 (patch)
tree0237b104390aa214f4d8baa1711bdae5e8fe3e61 /scripts/Makefile.am
parent99740b3fb07780d1e6e04af4c56144ed3f363ebc (diff)
downloadmariadb-git-62683b70fb3a6c386449480dd5f55da690676086.tar.gz
Improved fix for bug#18516 (also 19353):
1) Rename the old shell tool "mysql_upgrade", to avoid a name collision. 2) Improve the spec file, to explicitly use a temporary socket. scripts/mysql_upgrade_shell.sh: Rename: scripts/mysql_upgrade.sh -> scripts/mysql_upgrade_shell.sh scripts/Makefile.am: The old shell script "mysql_upgrade" must be renamed, so that its name does not collide with the new binary. support-files/mysql.spec.sh: The previous version was incomplete, as it did not cover the case where the DBA had configured a non-default socket file. Solve that by creating and explicitly providing a temporary directory for the socket just for the duration of "mysql_upgrade", which also can be better protected than the default socket.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 0f68b484f41..a339ebc5b8f 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -32,7 +32,7 @@ bin_SCRIPTS = @server_scripts@ \
mysqldumpslow \
mysql_explain_log \
mysql_tableinfo \
- mysql_upgrade \
+ mysql_upgrade_shell \
mysqld_multi \
mysql_create_system_tables
@@ -60,7 +60,7 @@ EXTRA_SCRIPTS = make_binary_distribution.sh \
mysql_explain_log.sh \
mysqld_multi.sh \
mysql_tableinfo.sh \
- mysql_upgrade.sh \
+ mysql_upgrade_shell.sh \
mysqld_safe.sh \
mysql_create_system_tables.sh
@@ -89,7 +89,7 @@ CLEANFILES = @server_scripts@ \
mysqldumpslow \
mysql_explain_log \
mysql_tableinfo \
- mysql_upgrade \
+ mysql_upgrade_shell \
mysqld_multi \
make_win_src_distribution \
mysql_create_system_tables