summaryrefslogtreecommitdiff
path: root/regex/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@sol>2009-11-24 23:15:47 +0000
committerVladislav Vaintroub <wlad@sol>2009-11-24 23:15:47 +0000
commit7377c50cb4f5b5dcb356a71787b53840d2c6ef3c (patch)
tree7ec79f7bfee3d63a780478c577294a5b729d6143 /regex/CMakeLists.txt
parent9abc7cf070fcb3d8e79ef0cb4d767d11affebb25 (diff)
downloadmariadb-git-7377c50cb4f5b5dcb356a71787b53840d2c6ef3c.tar.gz
implement convenience libraries
Diffstat (limited to 'regex/CMakeLists.txt')
-rwxr-xr-xregex/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/regex/CMakeLists.txt b/regex/CMakeLists.txt
index f02c5745ef3..46a36ae0758 100755
--- a/regex/CMakeLists.txt
+++ b/regex/CMakeLists.txt
@@ -17,6 +17,4 @@
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
SET(REGEX_SOURCES regcomp.c regerror.c regexec.c regfree.c reginit.c)
-USE_ABSOLUTE_FILENAMES(REGEX_SOURCES)
-ADD_LIBRARY(regex ${REGEX_SOURCES})
-
+ADD_CONVENIENCE_LIBRARY(regex STATIC ${REGEX_SOURCES})