summaryrefslogtreecommitdiff
path: root/regex/CMakeLists.txt
diff options
context:
space:
mode:
authorMagnus Blåudd <magnus.blaudd@sun.com>2009-10-09 09:53:29 +0200
committerMagnus Blåudd <magnus.blaudd@sun.com>2009-10-09 09:53:29 +0200
commit23d31a15d3f81e240990a85a6e4c1dac162d43b4 (patch)
tree7368f57718c5612d6ff7eeaa56cab4bb9d817597 /regex/CMakeLists.txt
parentc7470df2feb72cbab98201b2e0a9ebec72a7fdd9 (diff)
downloadmariadb-git-23d31a15d3f81e240990a85a6e4c1dac162d43b4.tar.gz
BUG#47850: too many files built in regex/
- Don't build split.c or debug.c since they are not part of the actual regex library
Diffstat (limited to 'regex/CMakeLists.txt')
-rwxr-xr-xregex/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/regex/CMakeLists.txt b/regex/CMakeLists.txt
index a3088c00357..2e3b18c7bb0 100755
--- a/regex/CMakeLists.txt
+++ b/regex/CMakeLists.txt
@@ -18,7 +18,7 @@ SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -D_DEBUG -DSAFEMALLOC -DSAFE_MUT
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
-SET(REGEX_SOURCES debug.c regcomp.c regerror.c regexec.c regfree.c reginit.c split.c)
+SET(REGEX_SOURCES regcomp.c regerror.c regexec.c regfree.c reginit.c)
IF(NOT SOURCE_SUBLIBS)
ADD_LIBRARY(regex ${REGEX_SOURCES})