summaryrefslogtreecommitdiff
path: root/mysql-test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Botchkov <holyfoot@mysql.com>2010-08-19 17:11:31 +0500
committerAlexey Botchkov <holyfoot@mysql.com>2010-08-19 17:11:31 +0500
commite1d285d1e019ac8920beb7a1a1f7e7e4c4046af7 (patch)
treea3f1470af565d3f422f23f34520a67cc9b91c152 /mysql-test/CMakeLists.txt
parente4da0b0af68f1efc966cd8e8cfb06834e44b09dd (diff)
downloadmariadb-git-e1d285d1e019ac8920beb7a1a1f7e7e4c4046af7.tar.gz
Bug#54129 Missing the execute bit for scripts
files for cmake had some minor bugs causing this. per-file comments: mysql-test/CMakeLists.txt Bug#54129 Missing the execute bit for scripts use same permissions as in the source folder mysql-test/t/disabled.def Bug#54129 Missing the execute bit for scripts mysqlhotcopy tests enabled scripts/CMakeLists.txt Bug#54129 Missing the execute bit for scripts chmod +x for the script files
Diffstat (limited to 'mysql-test/CMakeLists.txt')
-rw-r--r--mysql-test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
index 6ba53bd9c2c..b8eb11b2fea 100644
--- a/mysql-test/CMakeLists.txt
+++ b/mysql-test/CMakeLists.txt
@@ -16,6 +16,7 @@
INSTALL(
DIRECTORY .
DESTINATION ${INSTALL_MYSQLTESTDIR}
+ USE_SOURCE_PERMISSIONS
COMPONENT Test
PATTERN "var/" EXCLUDE
PATTERN "lib/My/SafeProcess" EXCLUDE