summaryrefslogtreecommitdiff
path: root/mysql-test/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2017-08-09 18:23:04 +0200
committerSergei Golubchik <serg@mariadb.org>2017-08-14 19:45:58 +0200
commitc872b10022180602fbd5b2b0310b6d1e343dff5a (patch)
treebf899ad9e77c58b4efc4f2b73c3f1a4e0253fab5 /mysql-test/CMakeLists.txt
parentc9db190fed4e368201703e3d1031e16abfd61e45 (diff)
downloadmariadb-git-c872b10022180602fbd5b2b0310b6d1e343dff5a.tar.gz
don't install same files twice
CMakeLists.txt - merge mistake, apparently include/CMakeLists.txt - install from CMAKE_CURRENT_BINARY_DIR. Only install from CMAKE_CURRENT_SOURCE_DIR, if it's different from CMAKE_CURRENT_BINARY_DIR mysql-test/CMakeLists.txt - INSTALL_MYSQL_TEST() macro installs everything, no need to install mtr separately once again mysql-test/lib/My/SafeProcess/CMakeLists.txt MYSQL_ADD_EXECUTABLE includes INSTALL sql-bench/CMakeLists.txt list files explicitly. don't install garbage, don't process 'foo' and 'foo.sh' separately, it's only one file to install, not two.
Diffstat (limited to 'mysql-test/CMakeLists.txt')
-rw-r--r--mysql-test/CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
index 1c7cfaf81da..996dacff319 100644
--- a/mysql-test/CMakeLists.txt
+++ b/mysql-test/CMakeLists.txt
@@ -32,12 +32,6 @@ IF(UNIX)
./mysql-test-run.pl mysql-test-run
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
)
- IF(INSTALL_MYSQLTESTDIR)
- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mtr
- ${CMAKE_CURRENT_BINARY_DIR}/mysql-test-run
- DESTINATION ${INSTALL_MYSQLTESTDIR}
- COMPONENT Test)
- ENDIF()
ENDIF()
IF(CMAKE_GENERATOR MATCHES "Visual Studio")