summaryrefslogtreecommitdiff
path: root/mysql-test/CMakeLists.txt
diff options
context:
space:
mode:
authorBjorn Munch <bjorn.munch@oracle.com>2013-01-15 09:56:36 +0100
committerBjorn Munch <bjorn.munch@oracle.com>2013-01-15 09:56:36 +0100
commit817f2ab90e891b90dbaaf0ce0c41c1df4b9a7daa (patch)
tree9e0889668eb97bc53628b2e79c867c1e0f62b669 /mysql-test/CMakeLists.txt
parente7ad5e36d467eff8faf5b39bfbc11af3469aed8d (diff)
downloadmariadb-git-817f2ab90e891b90dbaaf0ce0c41c1df4b9a7daa.tar.gz
A bit more intelligent processing of .in files in mysql-test/collections
Diffstat (limited to 'mysql-test/CMakeLists.txt')
-rw-r--r--mysql-test/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
index f360ef1c616..9c6db7082dc 100644
--- a/mysql-test/CMakeLists.txt
+++ b/mysql-test/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright (c) 2009, 2011, Oracle and/or its affiliates. All rights reserved.
+# Copyright (c) 2009, 2012, Oracle and/or its affiliates. All rights reserved.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -150,8 +150,10 @@ ENDMACRO()
FILE(GLOB infiles "collections/*.in")
FOREACH(collin ${infiles})
STRING(REPLACE ".in" "" collection ${collin})
+ STRING(REPLACE ".in" ".done" colldone ${collin})
# Only generate file once
- IF(NOT EXISTS ${collection})
+ IF(NOT EXISTS ${colldone})
PROCESS_COLLECTION_INCLUDE(${collin} ${collection})
+ FILE(APPEND ${colldone} "${collin}\n")
ENDIF()
ENDFOREACH()