summaryrefslogtreecommitdiff
path: root/mysql-test/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2010-03-17 19:56:22 +0100
committerVladislav Vaintroub <vvaintroub@mysql.com>2010-03-17 19:56:22 +0100
commit78a965861a3300c321775c65f54dd541bc5d3d49 (patch)
tree2d7936920bf092e313f7acff9b9c014bc576da0e /mysql-test/CMakeLists.txt
parent148c2c316df0dd2b6d29212d59d2339dedeaa272 (diff)
downloadmariadb-git-78a965861a3300c321775c65f54dd541bc5d3d49.tar.gz
Bug #52149 - packaging differences in CMake build
Corrected some packaging bugs: - install mysqlservices library - install libmysqlclient_r.so.{16,16.0.0} as links to libmysqlclient.so - install libmysqld-debug.a - install my_safe_process, my_safe_kill and symlinks to mysql-test-run.pl (mtr, mysql-test-run) into correct place ${INSTALL_MYSQLTESTDIR}
Diffstat (limited to 'mysql-test/CMakeLists.txt')
-rw-r--r--mysql-test/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
index 2cc65a9c82f..b8b7d08135f 100644
--- a/mysql-test/CMakeLists.txt
+++ b/mysql-test/CMakeLists.txt
@@ -46,7 +46,8 @@ IF(UNIX)
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
)
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mtr
- ${CMAKE_CURRENT_BINARY_DIR}/mysql-test-run DESTINATION mysql-test)
+ ${CMAKE_CURRENT_BINARY_DIR}/mysql-test-run
+ DESTINATION ${INSTALL_MYSQLTESTDIR})
ENDIF()
IF(CMAKE_GENERATOR MATCHES "Visual Studio")