summaryrefslogtreecommitdiff
path: root/mysql-test/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@sun.com>2010-09-03 00:17:08 +0200
committerVladislav Vaintroub <wlad@sun.com>2010-09-03 00:17:08 +0200
commit744c1013a2b429557fec07246e812fcc40ec00a8 (patch)
tree234bdbdbcdc03f2eba0151c62259c913667eafea /mysql-test/CMakeLists.txt
parent7e8d74505e2334db76a20360168e650149c99cc5 (diff)
downloadmariadb-git-744c1013a2b429557fec07246e812fcc40ec00a8.tar.gz
Small fixes in CMake:
create data dir correctly in initial_database target on Windows handle case where INSTALL_MYSQLTESTDIR is empty (e.g someone does not want to install tests)
Diffstat (limited to 'mysql-test/CMakeLists.txt')
-rw-r--r--mysql-test/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
index b8eb11b2fea..3c38e5772d0 100644
--- a/mysql-test/CMakeLists.txt
+++ b/mysql-test/CMakeLists.txt
@@ -13,6 +13,7 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+IF(INSTALL_MYSQLTESTDIR)
INSTALL(
DIRECTORY .
DESTINATION ${INSTALL_MYSQLTESTDIR}
@@ -28,6 +29,7 @@ INSTALL(
PATTERN "*.am" EXCLUDE
PATTERN "*.in" EXCLUDE
)
+ENDIF()
@@ -48,9 +50,11 @@ IF(UNIX)
./mysql-test-run.pl mysql-test-run
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
)
- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mtr
- ${CMAKE_CURRENT_BINARY_DIR}/mysql-test-run
- DESTINATION ${INSTALL_MYSQLTESTDIR})
+ IF(INSTALL_MYSQLTESTDIR)
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mtr
+ ${CMAKE_CURRENT_BINARY_DIR}/mysql-test-run
+ DESTINATION ${INSTALL_MYSQLTESTDIR})
+ ENDIF()
ENDIF()
IF(CMAKE_GENERATOR MATCHES "Visual Studio")