summaryrefslogtreecommitdiff
path: root/mysql-test/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2010-01-18 23:41:20 +0100
committerVladislav Vaintroub <vvaintroub@mysql.com>2010-01-18 23:41:20 +0100
commit5ca186b519a36293a40acdcba33b951459bd60ea (patch)
tree72119895ba54b2bd3e115aa4e418d11473063164 /mysql-test/CMakeLists.txt
parentb030db38afd987bad2bb51e109197c16c0460266 (diff)
downloadmariadb-git-5ca186b519a36293a40acdcba33b951459bd60ea.tar.gz
Add targets test-bt-fast and test-bt-debug
They are probably sometimes used by the bteam
Diffstat (limited to 'mysql-test/CMakeLists.txt')
-rw-r--r--mysql-test/CMakeLists.txt17
1 files changed, 16 insertions, 1 deletions
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
index c91940523b4..54203336dee 100644
--- a/mysql-test/CMakeLists.txt
+++ b/mysql-test/CMakeLists.txt
@@ -92,10 +92,14 @@ ELSE()
SET(TEST_EMBEDDED echo "Can not test embedded, not compiled in")
ENDIF()
-ADD_CUSTOM_TARGET(test-bt
+SET(TEST_BT_START
COMMAND ${SETCONFIG_COMMAND}
COMMAND ${SETOS_COMMAND}
COMMAND ${SET_ENV} MTR_BUILD_THREAD=auto
+)
+
+ADD_CUSTOM_TARGET(test-bt
+ ${TEST_BT_START}
COMMAND ${MTR_FORCE} --comment=normal --timer --skip-ndbcluster --report-features ${EXP}
COMMAND ${MTR_FORCE} --comment=ps --timer --skip-ndbcluster --ps-protocol ${EXP}
COMMAND ${MTR_FORCE} --comment=funcs1+ps --ps-protocol --reorder --suite=funcs_1 ${EXP}
@@ -107,4 +111,15 @@ ADD_CUSTOM_TARGET(test-bt
COMMAND ${TEST_EMBEDDED}
)
+ADD_CUSTOM_TARGET(test-bt-fast
+ ${TEST_BT_START}
+ COMMAND ${MTR_FORCE} --comment=ps --timer --skip-ndbcluster --ps-protocol --report-features ${EXP}
+ COMMAND ${MTR_FORCE} --comment=stress --suite=stress ${EXP}
+)
+
+ADD_CUSTOM_TARGET(test-bt-debug
+ ${TEST_BT_START}
+ COMMAND ${MTR_FORCE} --comment=debug --timer --skip-ndbcluster --skip-rpl --report-features ${EXP}
+)
+