summaryrefslogtreecommitdiff
path: root/libservices/CMakeLists.txt
diff options
context:
space:
mode:
authorKartik Soneji <kartiksoneji@rocketmail.com>2021-08-31 14:09:47 +0200
committerSergei Golubchik <serg@mariadb.org>2021-10-27 15:55:14 +0200
commitbf8b699f649b7f947e8ad8eeeb48c3d5f973be39 (patch)
treef7aaf1d7f2557c4f970e76f94735acfe44128930 /libservices/CMakeLists.txt
parentc356714d77150433e096fe8f04a2184495d42efb (diff)
downloadmariadb-git-bf8b699f649b7f947e8ad8eeeb48c3d5f973be39.tar.gz
MDEV-12933 sort out the compression library chaos
bzip2/lz4/lzma/lzo/snappy compression is now provided via *services* they're almost like normal services, but in include/providers/ and they're supposed to provide exactly the same interface as original compression libraries (but not everything, only enough of if for the code to compile). the services are implemented via dummy functions that return corresponding error values (LZMA_PROG_ERROR, LZO_E_INTERNAL_ERROR, etc). the actual compression libraries are linked into corresponding provider plugins. Providers are daemon plugins that when loaded replace service pointers to point to actual compression functions. That is, run-time dependency on compression libraries is now on plugins, and the server doesn't need any compression libraries to run, but will automatically support the compression when a plugin is loaded. InnoDB and Mroonga use compression plugins now. RocksDB doesn't, because it comes with standalone utility binaries that cannot load plugins.
Diffstat (limited to 'libservices/CMakeLists.txt')
-rw-r--r--libservices/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/libservices/CMakeLists.txt b/libservices/CMakeLists.txt
index 6b47bb53fdb..8c559cb07f5 100644
--- a/libservices/CMakeLists.txt
+++ b/libservices/CMakeLists.txt
@@ -39,7 +39,12 @@ SET(MYSQLSERVICES_SOURCES
wsrep_service.c
json_service.c
sql_service.c
- )
+ provider_service_bzip2.c
+ provider_service_lz4.c
+ provider_service_lzma.c
+ provider_service_lzo.c
+ provider_service_snappy.c
+)
ADD_CONVENIENCE_LIBRARY(mysqlservices ${MYSQLSERVICES_SOURCES})
INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR} COMPONENT Development)