summaryrefslogtreecommitdiff
path: root/libservices/CMakeLists.txt
diff options
context:
space:
mode:
authorMats Kindahl <mats.kindahl@oracle.com>2010-08-16 14:50:27 +0200
committerMats Kindahl <mats.kindahl@oracle.com>2010-08-16 14:50:27 +0200
commitb0836bd309e5b7857771ccae7096f0fdcdfc58e2 (patch)
tree60ab98cb19a6a71445b167b4cbc5308f59767cc9 /libservices/CMakeLists.txt
parent0ea3fb557deb017cd96f1e57694d56a5ace8c80c (diff)
parent7017775fd11c4249c1b64ff45564c88b94cf526f (diff)
downloadmariadb-git-b0836bd309e5b7857771ccae7096f0fdcdfc58e2.tar.gz
Merging with mysql-5.5-stage.
Diffstat (limited to 'libservices/CMakeLists.txt')
-rw-r--r--libservices/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/libservices/CMakeLists.txt b/libservices/CMakeLists.txt
index 79431ff65fe..396430fba12 100644
--- a/libservices/CMakeLists.txt
+++ b/libservices/CMakeLists.txt
@@ -15,7 +15,11 @@
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
-SET(MYSQLSERVICES_SOURCES my_snprintf_service.c thd_alloc_service.c)
+SET(MYSQLSERVICES_SOURCES
+ my_snprintf_service.c
+ thd_alloc_service.c
+ thd_wait_service.c
+ my_thread_scheduler_service.c)
ADD_LIBRARY(mysqlservices ${MYSQLSERVICES_SOURCES})
INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR})