summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authormsvensson@pilot.blaudden <>2007-03-27 23:56:48 +0200
committermsvensson@pilot.blaudden <>2007-03-27 23:56:48 +0200
commitb554258a8e453539d87a1a0a572b4d329b58d9eb (patch)
tree02a7e0d66c1854e1350626ab89132b36162066bd /include/Makefile.am
parent764d84852ef83c3584ca1e03bebd34b1b29d1f53 (diff)
downloadmariadb-git-b554258a8e453539d87a1a0a572b4d329b58d9eb.tar.gz
Bug#22508 BUILD/compile-dist fails due to problem with readline/libedit
- Move the link_sources command from top level Makefile into each subdir that need to link files
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index d40df7d8343..9be6738b3f4 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -16,7 +16,7 @@
# MA 02111-1307, USA
# FIXME 'abi_check' should be in BUILT_SOURCES, disabled for now
-BUILT_SOURCES = $(HEADERS_GEN)
+BUILT_SOURCES = $(HEADERS_GEN) link_sources
HEADERS_GEN = mysql_version.h my_config.h
HEADERS_ABI = mysql.h mysql_com.h mysql_time.h \
my_list.h my_alloc.h typelib.h
@@ -48,9 +48,10 @@ EXTRA_DIST = mysql_h.ic
DISTCLEANFILES = sched.h $(CLEANFILES)
link_sources:
- -$(RM) -fr readline
+ -$(RM) -f readline openssl
@readline_h_ln_cmd@
@yassl_h_ln_cmd@
+ echo timestamp > link_sources
my_config.h: ../config.h
$(CP) ../config.h my_config.h