summaryrefslogtreecommitdiff
path: root/include/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2016-06-10 13:47:00 +0200
committerSergei Golubchik <serg@mariadb.org>2016-06-14 13:59:55 +0200
commitc3c272cca45205b8ffc5c44b2cce136576649967 (patch)
tree78c8e3fa3cbe85efc8fcff1465214861b2d45227 /include/CMakeLists.txt
parent260699e91b095cdaa606f4abb82c26eb98830242 (diff)
downloadmariadb-git-c3c272cca45205b8ffc5c44b2cce136576649967.tar.gz
MDEV-10166 probes_mysql_nodtrace.h is not provided anymore by mariadb-10.0.25
backport of commit bba3d42 Author: Sergei Golubchik <serg@mariadb.org> Date: Sat Apr 30 10:27:42 2016 +0200 MDEV-9926 probes_mysql.h includes nonexisting files install private generated files
Diffstat (limited to 'include/CMakeLists.txt')
-rw-r--r--include/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/CMakeLists.txt b/include/CMakeLists.txt
index 33eaa28ae1e..219a2917917 100644
--- a/include/CMakeLists.txt
+++ b/include/CMakeLists.txt
@@ -69,3 +69,9 @@ INSTALL(DIRECTORY . DESTINATION ${INSTALL_INCLUDEDIR}/private COMPONENT Developm
PATTERN CMakeFiles EXCLUDE
PATTERN mysql EXCLUDE
REGEX "\\./(${EXCL_RE}$)" EXCLUDE)
+
+INSTALL(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/. DESTINATION ${INSTALL_INCLUDEDIR}/private COMPONENT Development
+ FILES_MATCHING PATTERN "*.h"
+ PATTERN CMakeFiles EXCLUDE
+ PATTERN mysql EXCLUDE
+ REGEX "\\./(${EXCL_RE}$)" EXCLUDE)