summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorOtto Kekäläinen <otto@kekalainen.net>2020-04-05 11:56:14 +0300
committerVicențiu-Marian Ciorbaru <vicentiu@mariadb.org>2020-04-23 10:07:07 +0300
commit7cbde2d0a29e214afba4d5d30af890002fbf7db2 (patch)
treec311faa024d8ae5b275a0a9c8f657f8785bd4136 /debian/autobake-deb.sh
parent13ec2ecc99e02d73a9877637ab27c0692c13b433 (diff)
downloadmariadb-git-7cbde2d0a29e214afba4d5d30af890002fbf7db2.tar.gz
Deb: Misc small fixes and cleanups
- Include binary wsrep_sst_rsync_wan previously omitted. - Don't build the embedded server. This saves a lot of time and around 500 MB of disk space. - Clean away unused override_dh_installcron. The package does not have any *.cron files, so this section is not needed. - Make mariadb-server run time depend on procps so pgrep works. The command pgrep is used in the maintainer scripts of mariadb-server, thus we should ensure it is found on the system. - Include build plugin func_test.so in test package. Don't include yet type_test.so since it fails (MDEV-22243). - Clean away obsolete Lintian overrides.
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index b5c3dc84f06..505d369f3a0 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -31,7 +31,7 @@ then
sed 's|DINSTALL_MYSQLTESTDIR=share/mysql/mysql-test|DINSTALL_MYSQLTESTDIR=false|' -i debian/rules
# Also skip building RocksDB, Mroonga etc to save even more time and disk space
- sed 's|-DDEB|-DPLUGIN_MROONGA=NO -DPLUGIN_ROCKSDB=NO -DPLUGIN_SPIDER=NO -DPLUGIN_OQGRAPH=NO -DPLUGIN_PERFSCHEMA=NO -DPLUGIN_SPHINX=NO -WITH_EMBEDDED_SERVER=OFF -DDEB|' -i debian/rules
+ sed 's|-DDEB|-DPLUGIN_MROONGA=NO -DPLUGIN_ROCKSDB=NO -DPLUGIN_SPIDER=NO -DPLUGIN_OQGRAPH=NO -DPLUGIN_PERFSCHEMA=NO -DPLUGIN_SPHINX=NO -DDEB|' -i debian/rules
fi
# Convert gcc version to numberical value. Format is Mmmpp where M is Major