summaryrefslogtreecommitdiff
path: root/debian/autobake-deb.sh
diff options
context:
space:
mode:
authorVicențiu Ciorbaru <vicentiu@mariadb.org>2021-01-28 23:29:43 +0200
committerVicențiu Ciorbaru <vicentiu@mariadb.org>2021-01-29 21:11:16 +0200
commit0921656734c25143d6070a75a1cbbee58fa42753 (patch)
tree6d2cc22d4c5a49fc817cd10ede68ce0fdbd9c388 /debian/autobake-deb.sh
parenta4d4836f2b58ff43d811dac610ac30b0c6f308f1 (diff)
downloadmariadb-git-0921656734c25143d6070a75a1cbbee58fa42753.tar.gz
Skip TokuDB within autobake-deb.sh
Skipping the package within debian/rules won't work because starting with Debian 10, the helper scripts read the control file before the recipe.
Diffstat (limited to 'debian/autobake-deb.sh')
-rwxr-xr-xdebian/autobake-deb.sh6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index ddef69bb350..5cf2398575a 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -91,6 +91,12 @@ then
sed '/Package: mariadb-plugin-rocksdb/,/^$/d' -i debian/control
fi
+## Skip TokuDB if arch is not amd64
+if [[ ! $(dpkg-architecture -q DEB_BUILD_ARCH) =~ amd64 ]]
+then
+ sed '/Package: mariadb-plugin-tokudb/,/^$/d' -i debian/control
+fi
+
# Always remove aws plugin, see -DNOT_FOR_DISTRIBUTION in CMakeLists.txt
sed '/Package: mariadb-plugin-aws-key-management-10.2/,/^$/d' -i debian/control