summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNarayanan V <v.narayanan@sun.com>2008-08-08 14:30:05 +0530
committerNarayanan V <v.narayanan@sun.com>2008-08-08 14:30:05 +0530
commitbd441c4d60e0a31086eab82ea7eb5efe86ca8ece (patch)
tree30fcd939d206cb1727deb6c43b23c0ca545afd65 /configure.in
parent3236c07b7f75473bc46da8a526ca9300c6d0b894 (diff)
downloadmariadb-git-bd441c4d60e0a31086eab82ea7eb5efe86ca8ece.tar.gz
WL#4380
1) Disabled abi_check rule for all compilers except gcc 2) restored the -dI option to retain the header information. Makefile.am: 1) changed all-local to depend on a configure variable that will be set based on if the compiler is gcc. 2) restored the -dI option removed earlier since now only gcc is being used. configure.in: Added a check to see if gcc is being used. If it is being used set the ABI_CHECK variable to the abi_check target. include/mysql.h.pp: The .pp file is changed to correspond to the option -dI.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index eeb2977e0ba..fea03dbf63a 100644
--- a/configure.in
+++ b/configure.in
@@ -444,6 +444,15 @@ AC_SUBST(HOSTNAME)
AC_SUBST(PERL)
AC_SUBST(PERL5)
+if expr "$CC" : ".*gcc.*"
+then
+ ABI_CHECK="abi_check"
+else
+ ABI_CHECK=""
+fi
+
+AC_SUBST(ABI_CHECK)
+
# Lock for PS
AC_PATH_PROG(PS, ps, ps)
AC_MSG_CHECKING("how to check if pid exists")