summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorunknown <cmiller@zippy.cornsilk.net>2007-06-14 14:24:59 -0400
committerunknown <cmiller@zippy.cornsilk.net>2007-06-14 14:24:59 -0400
commit4a009817ab562e3bc20edf496a6d0fda62ac3c1d (patch)
treec3a8d746e3ff181fd2f2036e33dce9a11a78b932 /configure.in
parent6f742c9053d793065de05b0394ebb6f1f0f58d55 (diff)
downloadmariadb-git-4a009817ab562e3bc20edf496a6d0fda62ac3c1d.tar.gz
Bug#21723: Should be able to dump core after setuid() under Linux
In many cases, binaries can no longer dump core after calling setuid(). Where the PR_SET_DUMPABLE macro is set, use the prctl() system call to tell the kernel that it's allowed to dump the core of the server. configure.in: Test system for "sys/prctl.h", to get access to prctl(). sql/mysqld.cc: Add a process-control operation that tells the Linux kernel that it is allowed to dump core after setuid().
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d995fd107ad..812bcff0d97 100644
--- a/configure.in
+++ b/configure.in
@@ -776,6 +776,7 @@ AC_CHECK_HEADERS(fcntl.h float.h floatingpoint.h ieeefp.h limits.h \
sys/timeb.h sys/types.h sys/un.h sys/vadvise.h sys/wait.h term.h \
unistd.h utime.h sys/utime.h termio.h termios.h sched.h crypt.h alloca.h \
sys/ioctl.h malloc.h sys/malloc.h sys/ipc.h sys/shm.h linux/config.h \
+ sys/prctl.h \
sys/resource.h sys/param.h)
#--------------------------------------------------------------------